Out-of-Bounds Affecting liblouis package, versions <3.0.0-3ubuntu0.2


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.85% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1704-LIBLOUIS-343566
  • published29 Aug 2017
  • disclosed29 Aug 2017

Introduced: 29 Aug 2017

CVE-2017-13742  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.04 liblouis to version 3.0.0-3ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblouis package and not the liblouis package as distributed by Ubuntu. See How to fix? for Ubuntu:17.04 relevant fixed versions and status.

There is a stack-based buffer overflow in Liblouis 3.2.0, triggered in the function includeFile() in compileTranslationTable.c, that will lead to a remote denial of service attack.