Improper Access Control Affecting libndp package, versions <1.4-2ubuntu1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.81% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1704-LIBNDP-287417
  • published13 Jun 2016
  • disclosed13 Jun 2016

Introduced: 13 Jun 2016

CVE-2016-3698  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.04 libndp to version 1.4-2ubuntu1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libndp package and not the libndp package as distributed by Ubuntu. See How to fix? for Ubuntu:17.04 relevant fixed versions and status.

libndp before 1.6, as used in NetworkManager, does not properly validate the origin of Neighbor Discovery Protocol (NDP) messages, which allows remote attackers to conduct man-in-the-middle attacks or cause a denial of service (network connectivity disruption) by advertising a node as a router from a non-local network.

CVSS Base Scores

version 3.1