Integer Overflow or Wraparound Affecting libplist package, versions <1.12-3.1ubuntu0.17.04.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.51% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1704-LIBPLIST-296171
  • published20 Apr 2017
  • disclosed20 Apr 2017

Introduced: 20 Apr 2017

CVE-2017-7982  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.04 libplist to version 1.12-3.1ubuntu0.17.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libplist package and not the libplist package as distributed by Ubuntu. See How to fix? for Ubuntu:17.04 relevant fixed versions and status.

Integer overflow in the plist_from_bin function in bplist.c in libimobiledevice/libplist before 2017-04-19 allows remote attackers to cause a denial of service (heap-based buffer over-read and application crash) via a crafted plist file.