Link Following Affecting libxfont1 package, versions <1:1.5.2-4ubuntu0.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.42% (34th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1704-LIBXFONT1-271093
  • published1 Dec 2017
  • disclosed1 Dec 2017

Introduced: 1 Dec 2017

CVE-2017-16611  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.04 libxfont1 to version 1:1.5.2-4ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxfont1 package and not the libxfont1 package as distributed by Ubuntu. See How to fix? for Ubuntu:17.04 relevant fixed versions and status.

In libXfont before 1.5.4 and libXfont2 before 2.0.3, a local attacker can open (but not read) files on the system as root, triggering tape rewinds, watchdogs, or similar mechanisms that can be triggered by opening files.

CVSS Base Scores

version 3.1