Out-of-Bounds Affecting mozjs38 package, versions <38.8.0~repack1-0ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
5.99% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1704-MOZJS38-272895
  • published31 Jan 2016
  • disclosed31 Jan 2016

Introduced: 31 Jan 2016

CVE-2016-1930  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.04 mozjs38 to version 38.8.0~repack1-0ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mozjs38 package and not the mozjs38 package as distributed by Ubuntu. See How to fix? for Ubuntu:17.04 relevant fixed versions and status.

Multiple unspecified vulnerabilities in the browser engine in Mozilla Firefox before 44.0 and Firefox ESR 38.x before 38.6 allow remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via unknown vectors.

References

CVSS Base Scores

version 3.1