Out-of-bounds Write Affecting gcab package, versions <0.7-4ubuntu0.1


Severity

Recommended
0.0
high
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.19% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1710-GCAB-285775
  • published12 Jan 2018
  • disclosed12 Jan 2018

Introduced: 12 Jan 2018

CVE-2018-5345  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.10 gcab to version 0.7-4ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gcab package and not the gcab package as distributed by Ubuntu. See How to fix? for Ubuntu:17.10 relevant fixed versions and status.

A stack-based buffer overflow within GNOME gcab through 0.7.4 can be exploited by malicious attackers to cause a crash or, potentially, execute arbitrary code via a crafted .cab file.