Use After Free Affecting nasm package, versions <2.13.01-2ubuntu0.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.41% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1710-NASM-371442
  • published21 Dec 2017
  • disclosed21 Dec 2017

Introduced: 21 Dec 2017

CVE-2017-17817  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.10 nasm to version 2.13.01-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nasm package and not the nasm package as distributed by Ubuntu. See How to fix? for Ubuntu:17.10 relevant fixed versions and status.

In Netwide Assembler (NASM) 2.14rc0, there is a use-after-free in pp_verror in asm/preproc.c that will cause a remote denial of service attack.