Improper Authentication Affecting packagekit package, versions <1.1.7-1ubuntu0.1


Severity

Recommended
high

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.38% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1710-PACKAGEKIT-270295
  • published23 Apr 2018
  • disclosed23 Apr 2018

Introduced: 23 Apr 2018

CVE-2018-1106  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.10 packagekit to version 1.1.7-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream packagekit package and not the packagekit package as distributed by Ubuntu. See How to fix? for Ubuntu:17.10 relevant fixed versions and status.

An authentication bypass flaw has been found in PackageKit before 1.1.10 that allows users without administrator privileges to install signed packages. A local attacker can use this vulnerability to install vulnerable packages to further compromise a system.