Loop with Unreachable Exit Condition ('Infinite Loop') Affecting quagga package, versions <1.1.1-3ubuntu0.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
30.16% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1710-QUAGGA-319651
  • published19 Feb 2018
  • disclosed19 Feb 2018

Introduced: 19 Feb 2018

CVE-2018-5381  (opens in a new tab)
CWE-835  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.10 quagga to version 1.1.1-3ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quagga package and not the quagga package as distributed by Ubuntu. See How to fix? for Ubuntu:17.10 relevant fixed versions and status.

The Quagga BGP daemon (bgpd) prior to version 1.2.3 has a bug in its parsing of "Capabilities" in BGP OPEN messages, in the bgp_packet.c:bgp_capability_msg_parse function. The parser can enter an infinite loop on invalid capabilities if a Multi-Protocol capability does not have a recognized AFI/SAFI, causing a denial of service.