Out-of-bounds Read Affecting quagga package, versions <1.1.1-3ubuntu0.2


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
14.84% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1710-QUAGGA-319671
  • published19 Feb 2018
  • disclosed19 Feb 2018

Introduced: 19 Feb 2018

CVE-2018-5380  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.10 quagga to version 1.1.1-3ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quagga package and not the quagga package as distributed by Ubuntu. See How to fix? for Ubuntu:17.10 relevant fixed versions and status.

The Quagga BGP daemon (bgpd) prior to version 1.2.3 can overrun internal BGP code-to-string conversion tables used for debug by 1 pointer value, based on input.