Out-of-Bounds Affecting quagga package, versions <1.1.1-3ubuntu0.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
74.2% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1710-QUAGGA-319817
  • published19 Feb 2018
  • disclosed19 Feb 2018

Introduced: 19 Feb 2018

CVE-2018-5378  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.10 quagga to version 1.1.1-3ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quagga package and not the quagga package as distributed by Ubuntu. See How to fix? for Ubuntu:17.10 relevant fixed versions and status.

The Quagga BGP daemon (bgpd) prior to version 1.2.3 does not properly bounds check the data sent with a NOTIFY to a peer, if an attribute length is invalid. Arbitrary data from the bgpd process may be sent over the network to a peer and/or bgpd may crash.