Information Exposure Affecting redmine package, versions <3.3.1-4+deb9u1build0.17.10.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.62% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1710-REDMINE-323367
  • published18 Oct 2017
  • disclosed18 Oct 2017

Introduced: 18 Oct 2017

CVE-2017-15577  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.10 redmine to version 3.3.1-4+deb9u1build0.17.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream redmine package and not the redmine package as distributed by Ubuntu. See How to fix? for Ubuntu:17.10 relevant fixed versions and status.

Redmine before 3.2.6 and 3.3.x before 3.3.3 mishandles the rendering of wiki links, which allows remote attackers to obtain sensitive information.