Cross-site Scripting (XSS) Affecting redmine package, versions <3.3.1-4+deb9u1build0.17.10.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.42% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1710-REDMINE-323442
  • published18 Oct 2017
  • disclosed18 Oct 2017

Introduced: 18 Oct 2017

CVE-2017-15570  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.10 redmine to version 3.3.1-4+deb9u1build0.17.10.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream redmine package and not the redmine package as distributed by Ubuntu. See How to fix? for Ubuntu:17.10 relevant fixed versions and status.

In Redmine before 3.2.8, 3.3.x before 3.3.5, and 3.4.x before 3.4.3, XSS exists in app/views/timelog/_list.html.erb via crafted column data.