CVE-2018-5702 Affecting transmission package, versions <2.92-2ubuntu3.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
11.93% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1710-TRANSMISSION-312372
  • published15 Jan 2018
  • disclosed15 Jan 2018

Introduced: 15 Jan 2018

CVE-2018-5702  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.10 transmission to version 2.92-2ubuntu3.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream transmission package and not the transmission package as distributed by Ubuntu. See How to fix? for Ubuntu:17.10 relevant fixed versions and status.

Transmission through 2.92 relies on X-Transmission-Session-Id (which is not a forbidden header for Fetch) for access control, which allows remote attackers to execute arbitrary RPC commands, and consequently write to arbitrary files, via POST requests to /transmission/rpc in conjunction with a DNS rebinding attack.