Out-of-bounds Read Affecting wavpack package, versions <5.1.0-2ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.92% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1710-WAVPACK-329608
  • published6 Feb 2018
  • disclosed6 Feb 2018

Introduced: 6 Feb 2018

CVE-2018-6767  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.10 wavpack to version 5.1.0-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream wavpack package and not the wavpack package as distributed by Ubuntu. See How to fix? for Ubuntu:17.10 relevant fixed versions and status.

A stack-based buffer over-read in the ParseRiffHeaderConfig function of cli/riff.c file of WavPack 5.1.0 allows a remote attacker to cause a denial-of-service attack or possibly have unspecified other impact via a maliciously crafted RF64 file.