Out-of-Bounds Affecting zsh package, versions <5.2-5ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.59% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1710-ZSH-351994
  • published27 Feb 2018
  • disclosed27 Feb 2018

Introduced: 27 Feb 2018

CVE-2014-10072  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:17.10 zsh to version 5.2-5ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream zsh package and not the zsh package as distributed by Ubuntu. See How to fix? for Ubuntu:17.10 relevant fixed versions and status.

In utils.c in zsh before 5.0.6, there is a buffer overflow when scanning very long directory paths for symbolic links.