CVE-2020-16126 Affecting accountsservice package, versions <0.6.45-1ubuntu1.3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.54% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-ACCOUNTSSERVICE-1035499
  • published3 Nov 2020
  • disclosed11 Nov 2020

Introduced: 3 Nov 2020

CVE-2020-16126  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 accountsservice to version 0.6.45-1ubuntu1.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream accountsservice package and not the accountsservice package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

An Ubuntu-specific modification to AccountsService in versions before 0.6.55-0ubuntu13.2, among other earlier versions, improperly dropped the ruid, allowing untrusted users to send signals to AccountService, thus stopping it from handling D-Bus messages in a timely fashion.

CVSS Base Scores

version 3.1