Directory Traversal Affecting accountsservice package, versions <0.6.45-1ubuntu1.3


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.05% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-ACCOUNTSSERVICE-317751
  • published22 Jul 2018
  • disclosed13 Jul 2018

Introduced: 13 Jul 2018

CVE-2018-14036  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 accountsservice to version 0.6.45-1ubuntu1.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream accountsservice package and not the accountsservice package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Directory Traversal with ../ sequences occurs in AccountsService before 0.6.50 because of an insufficient path check in user_change_icon_file_authorized_cb() in user.c.