Out-of-bounds Read Affecting aspell package, versions *


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.74% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-ASPELL-1164751
  • published10 Sept 2020
  • disclosed27 Jan 2020

Introduced: 27 Jan 2020

CVE-2019-20433  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 aspell.

NVD Description

Note: Versions mentioned in the description apply only to the upstream aspell package and not the aspell package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

libaspell.a in GNU Aspell before 0.60.8 has a buffer over-read for a string ending with a single '\0' byte, if the encoding is set to ucs-2 or ucs-4 outside of the application, as demonstrated by the ASPELL_CONF environment variable.

CVSS Base Scores

version 3.1