Improper Input Validation Affecting bubblewrap package, versions <0.2.1-1ubuntu0.1+esm2


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.58% (47th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-BUBBLEWRAP-452807
  • published29 May 2019
  • disclosed29 May 2019

Introduced: 29 May 2019

CVE-2019-12439  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 bubblewrap to version 0.2.1-1ubuntu0.1+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream bubblewrap package and not the bubblewrap package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

bubblewrap.c in Bubblewrap before 0.3.3 misuses temporary directories in /tmp as a mount point. In some particular configurations (related to XDG_RUNTIME_DIR), a local attacker may abuse this flaw to prevent other users from executing bubblewrap or potentially execute code.