Directory Traversal Affecting cgit package, versions <1.1+git2.10.2-3ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
91.88% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-CGIT-275015
  • published3 Aug 2018
  • disclosed3 Aug 2018

Introduced: 3 Aug 2018

CVE-2018-14912  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 cgit to version 1.1+git2.10.2-3ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cgit package and not the cgit package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

cgit_clone_objects in CGit before 1.2.1 has a directory traversal vulnerability when enable-http-clone=1 is not turned off, as demonstrated by a cgit/cgit.cgi/git/objects/?path=../ request.