CVE-2024-26540 Affecting cimg package, versions <1.7.9+dfsg-2ubuntu0.18.04.2+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.31% (23rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-CIMG-10287651
  • published1 Jun 2025
  • disclosed15 Mar 2024

Introduced: 15 Mar 2024

CVE-2024-26540  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 cimg to version 1.7.9+dfsg-2ubuntu0.18.04.2+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cimg package and not the cimg package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

A heap-based buffer overflow in Clmg before 3.3.3 can occur via a crafted file to cimg_library::CImg<unsigned char>::_load_analyze.