CVE-2024-11584 Affecting cloud-init package, versions <23.1.2-0ubuntu0~18.04.1+esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.14% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-CLOUDINIT-10566905
  • published1 Jul 2025
  • disclosed26 Jun 2025

Introduced: 26 Jun 2025

CVE-2024-11584  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 cloud-init to version 23.1.2-0ubuntu0~18.04.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cloud-init package and not the cloud-init package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

cloud-init through 25.1.2 includes the systemd socket unit cloud-init-hotplugd.socket with default SocketMode that grants 0666 permissions, making it world-writable. This is used for the "/run/cloud-init/hook-hotplug-cmd" FIFO. An unprivileged user could trigger hotplug-hook commands.

CVSS Base Scores

version 3.1