Use of Insufficiently Random Values Affecting cloud-init package, versions <20.2-45-g5f7825e2-0ubuntu1~18.04.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.44% (36th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-CLOUDINIT-1128313
  • published20 Jan 2022
  • disclosed5 Feb 2020

Introduced: 5 Feb 2020

CVE-2020-8631  (opens in a new tab)
CWE-330  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 cloud-init to version 20.2-45-g5f7825e2-0ubuntu1~18.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cloud-init package and not the cloud-init package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

cloud-init through 19.4 relies on Mersenne Twister for a random password, which makes it easier for attackers to predict passwords, because rand_str in cloudinit/util.py calls the random.choice function.

CVSS Base Scores

version 3.1