Integer Overflow or Wraparound Affecting corosync package, versions <2.4.3-0ubuntu1.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.11% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-COROSYNC-266919
  • published12 Apr 2018
  • disclosed12 Apr 2018

Introduced: 12 Apr 2018

CVE-2018-1084  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 corosync to version 2.4.3-0ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream corosync package and not the corosync package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

corosync before version 2.4.4 is vulnerable to an integer overflow in exec/totemcrypto.c.

CVSS Base Scores

version 3.1