Incorrect Permission Assignment for Critical Resource Affecting debian-lan-config package, versions <0.23+deb9u1build0.18.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.5% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-DEBIANLANCONFIG-674784
  • published17 Sept 2020
  • disclosed23 Dec 2019

Introduced: 23 Dec 2019

CVE-2019-3467  (opens in a new tab)
CWE-732  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 debian-lan-config to version 0.23+deb9u1build0.18.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream debian-lan-config package and not the debian-lan-config package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Debian-edu-config all versions < 2.11.10, a set of configuration files used for Debian Edu, and debian-lan-config < 0.26, configured too permissive ACLs for the Kerberos admin server, which allowed password changes for other Kerberos user principals.

CVSS Base Scores

version 3.1