Out-of-bounds Read Affecting elfutils package, versions <0.170-0.4ubuntu0.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.26% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-ELFUTILS-349021
  • published9 Feb 2019
  • disclosed9 Feb 2019

Introduced: 9 Feb 2019

CVE-2019-7665  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 elfutils to version 0.170-0.4ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream elfutils package and not the elfutils package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

In elfutils 0.175, a heap-based buffer over-read was discovered in the function elf32_xlatetom in elf32_xlatetom.c in libelf. A crafted ELF input can cause a segmentation fault leading to denial of service (program crash) because ebl_core_note does not reject malformed core file notes.

CVSS Base Scores

version 3.1