CVE-2019-1010083 Affecting flask package, versions <0.12.2-3ubuntu0.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.83% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-FLASK-1173717
  • published26 Feb 2026
  • disclosed17 Jul 2019

Introduced: 17 Jul 2019

CVE-2019-1010083  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 flask to version 0.12.2-3ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream flask package and not the flask package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

The Pallets Project Flask before 1.0 is affected by: unexpected memory usage. The impact is: denial of service. The attack vector is: crafted encoded JSON data. The fixed version is: 1. NOTE: this may overlap CVE-2018-1000656.

CVSS Base Scores

version 3.1