Out-of-bounds Write Affecting giflib package, versions <5.1.4-2ubuntu0.1+esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.25% (67th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-GIFLIB-2804409
  • published27 Apr 2022
  • disclosed25 Apr 2022

Introduced: 25 Apr 2022

CVE-2022-28506  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 giflib to version 5.1.4-2ubuntu0.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream giflib package and not the giflib package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

There is a heap-buffer-overflow in GIFLIB 5.2.1 function DumpScreen2RGB() in gif2rgb.c:298:45.

CVSS Base Scores

version 3.1