Buffer Overflow Affecting giflib package, versions <5.1.4-2ubuntu0.1+esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.35% (28th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-GIFLIB-5861940
  • published26 Aug 2023
  • disclosed25 Aug 2023

Introduced: 25 Aug 2023

CVE-2023-39742  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 giflib to version 5.1.4-2ubuntu0.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream giflib package and not the giflib package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

giflib v5.2.1 was discovered to contain a segmentation fault via the component getarg.c.

CVSS Base Scores

version 3.1