Uncontrolled Search Path Element Affecting git package, versions <1:2.17.1-1ubuntu0.12


medium

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
RHEL
7.8 high
Expand this section
NVD
7.8 high
Expand this section
SUSE
7.3 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-UBUNTU1804-GIT-2949718
  • published 14 Jul 2022
  • disclosed 12 Jul 2022

How to fix?

Upgrade Ubuntu:18.04 git to version 1:2.17.1-1ubuntu0.12 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream git package. See How to fix? for Ubuntu:18.04 relevant versions.

Git is a distributed revision control system. Git prior to versions 2.37.1, 2.36.2, 2.35.4, 2.34.4, 2.33.4, 2.32.3, 2.31.4, and 2.30.5, is vulnerable to privilege escalation in all platforms. An unsuspecting user could still be affected by the issue reported in CVE-2022-24765, for example when navigating as root into a shared tmp directory that is owned by them, but where an attacker could create a git repository. Versions 2.37.1, 2.36.2, 2.35.4, 2.34.4, 2.33.4, 2.32.3, 2.31.4, and 2.30.5 contain a patch for this issue. The simplest way to avoid being affected by the exploit described in the example is to avoid running git as root (or an Administrator in Windows), and if needed to reduce its use to a minimum. While a generic workaround is not possible, a system could be hardened from the exploit described in the example by removing any such repository if it exists already and creating one as root to block any future attacks.