Arbitrary Code Injection Affecting gnupg2 package, versions <2.2.4-1ubuntu1.6



    Attack Complexity High
    Confidentiality High
Expand this section
6.5 medium
Expand this section
6.8 medium
Expand this section
5.9 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-UBUNTU1804-GNUPG2-2940674
  • published 4 Jul 2022
  • disclosed 1 Jul 2022

How to fix?

Upgrade Ubuntu:18.04 gnupg2 to version 2.2.4-1ubuntu1.6 or higher.

NVD Description

Note: Versions mentioned in the description apply to the upstream gnupg2 package. See How to fix? for Ubuntu:18.04 relevant versions.

GnuPG through 2.3.6, in unusual situations where an attacker possesses any secret-key information from a victim's keyring and other constraints (e.g., use of GPGME) are met, allows signature forgery via injection into the status line.