Information Exposure Affecting gnutls28 package, versions *


low

Snyk CVSS

    Attack Complexity High
    Scope Changed
    Confidentiality High

    Threat Intelligence

    EPSS 0.05% (15th percentile)
Expand this section
NVD
5.6 medium
Expand this section
SUSE
5.3 medium
Expand this section
Red Hat
4.7 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-UBUNTU1804-GNUTLS28-340583
  • published 3 Dec 2018
  • disclosed 3 Dec 2018

How to fix?

There is no fixed version for Ubuntu:18.04 gnutls28.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnutls28 package and not the gnutls28 package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

A Bleichenbacher type side-channel based padding oracle attack was found in the way gnutls handles verification of RSA decrypted PKCS#1 v1.5 data. An attacker who is able to run process on the same physical core as the victim process, could use this to extract plaintext or in some cases downgrade any TLS connections to a vulnerable server.