CVE-2019-11065 Affecting gradle package, versions <4.4.1-5ubuntu2~18.04+esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.36% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-GRADLE-343113
  • published10 Apr 2019
  • disclosed10 Apr 2019

Introduced: 10 Apr 2019

CVE-2019-11065  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 gradle to version 4.4.1-5ubuntu2~18.04+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gradle package and not the gradle package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Gradle versions from 1.4 to 5.3.1 use an insecure HTTP URL to download dependencies when the built-in JavaScript or CoffeeScript Gradle plugins are used. Dependency artifacts could have been maliciously compromised by a MITM attack against the ajax.googleapis.com web site.

CVSS Base Scores

version 3.1