Out-of-bounds Write Affecting gsoap package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.99% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-GSOAP-345485
  • published9 Feb 2019
  • disclosed9 Feb 2019

Introduced: 9 Feb 2019

CVE-2019-7659  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 gsoap.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gsoap package and not the gsoap package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Genivia gSOAP 2.7.x and 2.8.x before 2.8.75 allows attackers to cause a denial of service (application abort) or possibly have unspecified other impact if a server application is built with the -DWITH_COOKIES flag. This affects the C/C++ libgsoapck/libgsoapck++ and libgsoapssl/libgsoapssl++ libraries, as these are built with that flag.