CVE-2024-32609 Affecting hdf5 package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.8% (52nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-HDF5-10288807
  • published28 Feb 2026
  • disclosed14 May 2024

Introduced: 14 May 2024

CVE-2024-32609  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 hdf5.

NVD Description

Note: Versions mentioned in the description apply only to the upstream hdf5 package and not the hdf5 package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

HDF5 Library through 1.14.3 allows stack consumption in the function H5E_printf_stack in H5Eint.c.