Information Exposure Affecting kafka package, versions *


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
6.2% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-KAFKA-1657137
  • published21 Mar 2026
  • disclosed22 Sept 2021

Introduced: 22 Sep 2021

CVE-2021-38153  (opens in a new tab)
CWE-203  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 kafka.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kafka package and not the kafka package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Some components in Apache Kafka use Arrays.equals to validate a password or key, which is vulnerable to timing attacks that make brute force attacks for such credentials more likely to be successful. Users should upgrade to 2.8.1 or higher, or 3.0.0 or higher where this vulnerability has been fixed. The affected versions include Apache Kafka 2.0.0, 2.0.1, 2.1.0, 2.1.1, 2.2.0, 2.2.1, 2.2.2, 2.3.0, 2.3.1, 2.4.0, 2.4.1, 2.5.0, 2.5.1, 2.6.0, 2.6.1, 2.6.2, 2.7.0, 2.7.1, and 2.8.0.

References

CVSS Base Scores

version 3.1