Improper Input Validation Affecting kf5-messagelib package, versions *


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.1% (62nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-KF5MESSAGELIB-280293
  • published2 Dec 2018
  • disclosed12 Mar 2020

Introduced: 2 Dec 2018

CVE-2018-19516  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 kf5-messagelib.

NVD Description

Note: Versions mentioned in the description apply only to the upstream kf5-messagelib package and not the kf5-messagelib package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

messagepartthemes/default/defaultrenderer.cpp in messagelib in KDE Applications before 18.12.0 does not properly restrict the handling of an http-equiv="REFRESH" value.

CVSS Base Scores

version 3.1