Uncontrolled Recursion Affecting libcroco package, versions *


low

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Availability High

    Threat Intelligence

    EPSS 0.18% (54th percentile)
Expand this section
NVD
7.1 high
Expand this section
SUSE
7.1 high
Expand this section
Red Hat
7.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-UBUNTU1804-LIBCROCO-1146420
  • published 25 Apr 2022
  • disclosed 12 May 2020

How to fix?

There is no fixed version for Ubuntu:18.04 libcroco.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcroco package and not the libcroco package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

libcroco through 0.6.13 has excessive recursion in cr_parser_parse_any_core in cr-parser.c, leading to stack consumption.