Improper Input Validation Affecting libemail-address-perl package, versions *


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.54% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBEMAILADDRESSPERL-278844
  • published6 Oct 2015
  • disclosed6 Oct 2015

Introduced: 6 Oct 2015

CVE-2015-7686  (opens in a new tab)
CWE-20  (opens in a new tab)
CWE-399  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 libemail-address-perl.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libemail-address-perl package and not the libemail-address-perl package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Algorithmic complexity vulnerability in Address.pm in the Email-Address module 1.908 and earlier for Perl allows remote attackers to cause a denial of service (CPU consumption) via a crafted string containing a list of e-mail addresses in conjunction with parenthesis characters that can be associated with nested comments. NOTE: the default configuration in 1.908 mitigates this vulnerability but misparses certain realistic comments.

CVSS Base Scores

version 3.1