Race Condition Affecting libgcrypt20 package, versions <1.8.1-4ubuntu1.2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.55% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBGCRYPT20-467122
  • published29 Aug 2019
  • disclosed25 Sept 2019

Introduced: 29 Aug 2019

CVE-2019-13627  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 libgcrypt20 to version 1.8.1-4ubuntu1.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgcrypt20 package and not the libgcrypt20 package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

It was discovered that there was a ECDSA timing attack in the libgcrypt20 cryptographic library. Version affected: 1.8.4-5, 1.7.6-2+deb9u3, and 1.6.3-2+deb8u4. Versions fixed: 1.8.5-2 and 1.6.3-2+deb8u7.

CVSS Base Scores

version 3.1