Out-of-bounds Read Affecting libgxps package, versions *


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.19% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBGXPS-284499
  • published6 May 2018
  • disclosed6 May 2018

Introduced: 6 May 2018

CVE-2018-10767  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:18.04 libgxps.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libgxps package and not the libgxps package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

There is a stack-based buffer over-read in calling GLib in the function gxps_images_guess_content_type of gxps-images.c in libgxps through 0.3.0 because it does not reject negative return values from a g_input_stream_read call. A crafted input will lead to a remote denial of service attack.