Integer Overflow or Wraparound Affecting libiberty package, versions <20170913-1ubuntu0.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.46% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBIBERTY-561080
  • published18 Oct 2018
  • disclosed18 Oct 2018

Introduced: 18 Oct 2018

CVE-2018-18483  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 libiberty to version 20170913-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libiberty package and not the libiberty package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

The get_count function in cplus-dem.c in GNU libiberty, as distributed in GNU Binutils 2.31, allows remote attackers to cause a denial of service (malloc called with the result of an integer-overflowing calculation) or possibly have unspecified other impact via a crafted string, as demonstrated by c++filt.

CVSS Base Scores

version 3.1