Use of Externally-Controlled Format String Affecting libinput package, versions <1.10.4-1ubuntu0.18.04.3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.38% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBINPUT-2769608
  • published20 Apr 2022
  • disclosed2 Jun 2022

Introduced: 20 Apr 2022

CVE-2022-1215  (opens in a new tab)
CWE-134  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 libinput to version 1.10.4-1ubuntu0.18.04.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libinput package and not the libinput package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

A format string vulnerability was found in libinput

CVSS Base Scores

version 3.1