Improper Input Validation Affecting liblivemedia package, versions <2018.02.18-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.17% (80th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBLIVEMEDIA-455614
  • published28 Feb 2019
  • disclosed28 Feb 2019

Introduced: 28 Feb 2019

CVE-2019-9215  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 liblivemedia to version 2018.02.18-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblivemedia package and not the liblivemedia package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

In Live555 before 2019.02.27, malformed headers lead to invalid memory access in the parseAuthorizationHeader function.

CVSS Base Scores

version 3.1