Out-of-bounds Write Affecting liblouis package, versions <3.5.0-1ubuntu0.4


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.13% (66th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBLOUIS-2849568
  • published1 Jun 2022
  • disclosed2 Jun 2022

Introduced: 1 Jun 2022

CVE-2022-31783  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 liblouis to version 3.5.0-1ubuntu0.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblouis package and not the liblouis package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Liblouis 3.21.0 has an out-of-bounds write in compileRule in compileTranslationTable.c, as demonstrated by lou_trace.

CVSS Base Scores

version 3.1