Out-of-bounds Read Affecting liblouis package, versions <3.5.0-1ubuntu0.3


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.72% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBLOUIS-343552
  • published25 Sept 2018
  • disclosed21 Sept 2018

Introduced: 21 Sep 2018

CVE-2018-17294  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 liblouis to version 3.5.0-1ubuntu0.3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblouis package and not the liblouis package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

The matchCurrentInput function inside lou_translateString.c of Liblouis prior to 3.7 does not check the input string's length, allowing attackers to cause a denial of service (application crash via out-of-bounds read) by crafting an input file with certain translation dictionaries.

CVSS Base Scores

version 3.1