CVE-2026-45191 Affecting libnet-cidr-lite-perl package, versions <0.21-1ubuntu0.18.04.1~esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.3% (23rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBNETCIDRLITEPERL-17339472
  • published18 Jun 2026
  • disclosed10 May 2026

Introduced: 10 May 2026

CVE-2026-45191  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 libnet-cidr-lite-perl to version 0.21-1ubuntu0.18.04.1~esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libnet-cidr-lite-perl package and not the libnet-cidr-lite-perl package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Net::CIDR::Lite versions before 0.24 for Perl does not properly consider extraneous zero characters in CIDR mask values, which may allow IP ACL bypass.

Mask forms like "/00" and "/01" pass validation and parse to the same prefix as their unpadded value.

See also CVE-2026-45190.

CVSS Base Scores

version 3.1