Out-of-bounds Read Affecting libonig package, versions *


medium

Snyk CVSS

    Attack Complexity Low
    Availability High

    Threat Intelligence

    EPSS 0.49% (77th percentile)
Expand this section
NVD
7.5 high
Expand this section
SUSE
7.5 high
Expand this section
Red Hat
4.8 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-UBUNTU1804-LIBONIG-536321
  • published 25 Nov 2019
  • disclosed 25 Nov 2019

How to fix?

There is no fixed version for Ubuntu:18.04 libonig.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libonig package and not the libonig package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

Oniguruma through 6.9.3, as used in PHP 7.3.x and other products, has a heap-based buffer over-read in str_lower_case_match in regexec.c.