CVE-2022-24891 Affecting libowasp-esapi-java package, versions <2.1.0-3ubuntu0.18.04.1~esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.72% (77th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU1804-LIBOWASPESAPIJAVA-2932397
  • published17 Apr 2026
  • disclosed27 Apr 2022

Introduced: 27 Apr 2022

CVE-2022-24891  (opens in a new tab)

How to fix?

Upgrade Ubuntu:18.04 libowasp-esapi-java to version 2.1.0-3ubuntu0.18.04.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libowasp-esapi-java package and not the libowasp-esapi-java package as distributed by Ubuntu. See How to fix? for Ubuntu:18.04 relevant fixed versions and status.

ESAPI (The OWASP Enterprise Security API) is a free, open source, web application security control library. Prior to version 2.3.0.0, there is a potential for a cross-site scripting vulnerability in ESAPI caused by a incorrect regular expression for "onsiteURL" in the antisamy-esapi.xml configuration file that can cause "javascript:" URLs to fail to be correctly sanitized. This issue is patched in ESAPI 2.3.0.0. As a workaround, manually edit the antisamy-esapi.xml configuration files to change the "onsiteURL" regular expression. More information about remediation of the vulnerability, including the workaround, is available in the maintainers' release notes and security bulletin.

CVSS Base Scores

version 3.1